Centos6.5下docker 环境搭建

linux cooljun 73℃ 0评论

运行docker Linux内核版本需要在3.8以上,针对centos6.5 内核为2.6的系统需要先升级内核.不然会特别卡,退出容器.  【linux内核升级】centos6.4或者6.5使用yum的elrepo源升级内核

安装docker

直接使用命令: yum install docker-io 是会报错的!!! 提示:No package docker-io available.

需要先安装yum 源

yum -y install http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum install docker-io

就可以正常安装了!!

在安装的过程中由于dns的问题报了错,所以要设置好自己的dns确保服务器能连接到外网,我当时设置的dns为:

vim /etc/resolv.conf 
nameserver 8.8.8.8
nameserver 8.8.4.4

启动docker

service docker start

查看docker版本:

[root@localhost ]# docker version
Client version: 1.7.1
Client API version: 1.19
Go version (client): go1.4.2
Git commit (client): 786b29d/1.7.1
OS/Arch (client): linux/amd64
Server version: 1.7.1
Server API version: 1.19
Go version (server): go1.4.2
Git commit (server): 786b29d/1.7.1
OS/Arch (server): linux/amd64

查看docker日志.

cat /var/log/docke

至此,docker安装完成!!!

卸载docker

列出你安装过的包

[root@localhost ~]# yum list installed | grep docker
docker-io.x86_64                     1.7.1-2.el6                        @epel

删除软件包

yum -y remove docker-io.x86_64
删除镜像/容器等
rm -rf /var/lib/docker

升级docker版本为1.10.3

升级之前停止docker服务,并将原有的docker服务进行备份. mv /usr/bin/docker /usr/bin/docker.bak

nohup wget -c https://get.docker.com/builds/Linux/x86_64/docker-1.10.3 -O /usr/bin/docker

给执行权限:chmod 755 /usr/bin/docker 然后重启服务,并查看版本.

转载请注明:cooljun小站 » Centos6.5下docker 环境搭建

如果你觉得这篇文章对你有帮助,请支持我继续更新网站 !捐赠本站
喜欢 (0)or分享 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址